P
PinokioPierrunoYT

Supir - High RAM / VRAM usage

It uses much Ram and it run for 400 seconds and still nothing
M
Morpheus44d ago
Maybe the wrong torch version. Please post your logs.
M
moony43d ago
I've been waiting for about 30 minutes for something else to happen, but it hasn't continued. What could be causing this issue with the installer for SUPIR?
M
Morpheus43d ago
@moony You are using pinokio 0.2.7 - Version 1 Apps need Pinokio 1.0.15 or higher - Version 1.2 Apps need Pinokio 1.2 or higher Please close Pinokio. Download and install this version over your existing one and try again. Let me know if this fix your error, please. https://github.com/pinokiocomputer/pinokio/releases/tag/1.2.0
GitHub
Release 1.2.0 · pinokiocomputer/pinokio
Wifi Sharing: Use Pinokio from the same WIFI network Mobile Support: UI now can be loaded from mobile devices (to be used along with wifi sharing, to access Pinokio from any mobile device from the ...
M
moony43d ago
Thanks
M
Morpheus43d ago
When you see your prompt at the end (env) D:\andSoOn\app> It always means it got aborted. No need to wait at this point.
M
moony43d ago
I update Pinokio and i try restarting the software to run Supir, and practically, for the first time, my 32GB of RAM were completely filled (Supir did not start)
L
Lytanshade43d ago
i feel like we need a check pinochio version at the start of the install scripts...
M
Morpheus43d ago
@moonyYour installation looks good to me. No errors at least. But I can't tell if updating fixes your issue. I can't see it in your logs. How much VRAM do you have. You probably need 16GB or even more.
M
moony43d ago
I have seen that Supir works perfectly with 12gb of vram (I have a rtx 3060). What filled up was the RAM, not the VRAM, as I mentioned; Supir didn't even start I will restart it, it seemed very strange to me
M
Morpheus43d ago
Do you remember this script V message some people encounter? This is that check. But sometimes it thinks Pinokio isn't up to ate although it is. And sometimes it say nothing although it should.
No description
L
Lytanshade43d ago
try using this image: and you'll need to close browser tabs etc and get your system used VRAM down to almost nothing before running it
No description
M
moony43d ago
No description
M
Morpheus43d ago
Wrong pic. Here you see it. The one I sent first, shows when it goes wrong. I think it is rather a message to use verified scripts. That's maybe what script v means. This here now is for version check.
No description
M
Morpheus43d ago
Really that makes me hope. Where have you seen that? I only have 12GB -.- And Cocktailpeanut said it has a peak of 15GB
M
moony43d ago
Maybe it's my poor English, but what I want to say is that the webui for Supir didn't even start; it got stuck in the first part. Now, for some reason, mu pc fills up all its ram without even running Supir or opening the webui
No description
M
moony43d ago
😕
L
Lytanshade43d ago
yeah you're trying to use ungodly amount of memory 😆 i upscaled that image i linked x4 using around 12GB vram total
M
Morpheus43d ago
@moonyAlright. But they are using several flags to reduce VRAM usage I think. --use-tile-vae --loading-half-params For now please check 2 things. Just to exclude this is causing hte issue... do you have the file CKPT_PTH.py in your app folder? Do you have SUPIR_v0.yaml in your app\optioins folder?
L
Lytanshade43d ago
lol ok, issue is loading everything in RAM on start up haha ouch
L
Lytanshade43d ago
No description
L
Lytanshade43d ago
page file and step away while it lags until loaded
M
moony43d ago
Exactly, that's what's happening to me.
M
Morpheus43d ago
How much virtual RAM do you both have?
M
moony43d ago
No description
M
Morpheus43d ago
IN your app folder oh it's outside? o.O
M
Morpheus43d ago
Am I nuts? this means it should be inside. Or not? o.O
No description
M
moony43d ago
Could the problem be resolved if I reinstall supir? 🤔
M
Morpheus43d ago
I don't think so. Your installatino is fine. Let's try a few things
L
Lytanshade43d ago
i need to increase my page file size a little, Supir works for me though. 32GB + 25GB page file. increasing my now since it's too close for comfort
M
moony43d ago
😔
M
Morpheus43d ago
First of all increase your virtual memory to 64 GB start and end value and restart windows please. @Lytanshade is your CKPT_PTH.py file also only outside of the app folder. And none inside?
M
moony43d ago
There is a button that says restart, I clicked on it, now it showed me the interface to start the web UI but it doesn't initiate. Now I'm trying to uninstall it (to download it again) and this error appears...
No description
L
Lytanshade43d ago
uses ~45GB to get past the initial loading state
No description
L
Lytanshade43d ago
outside and in it's using RAM to do calculation stuff as it loads. 45GB of RAM
L
Lytanshade43d ago
it's surprisingly well behaved with a 1024x1024 1:1 upscale. adds nice detail. spikes a little over 12GB VRAM but mostly sat like this:
No description
L
Lytanshade43d ago
1024x1024 upscaler factor: 2 uses these resources:
No description
M
Morpheus43d ago
Where and when do you see hat error. I'm confused. When you try to install it again?
M
moony43d ago
Yes, although it is solved by restarting the computer. Now I will try to download it again. In case the errors continue, I will be genuinely worried
M
Morpheus43d ago
If you still deleted supir then I guess for some reason pinokio still tired to access it? Doesn't make much sense. Because when you delete the app, the path throwing this error doesn't exist anymore. 🤔
C
cocktailpeanut43d ago
yeah the script uses the same flags. see here: https://github.com/cocktailpeanutlabs/supir/blob/main/start.js#L11
GitHub
supir/start.js at main · cocktailpeanutlabs/supir
Contribute to cocktailpeanutlabs/supir development by creating an account on GitHub.
C
cocktailpeanut43d ago
not sure why it's taking up so much memory who here actually got it to work (for upscaling more than 1x)
L
Lytanshade43d ago
i have it working
C
cocktailpeanut43d ago
oh ok thanks. just watching these forum posts sometimes makes me doubt the reality, like "am i the only one who has it working?"
L
Lytanshade43d ago
doing a x8 atm ooh ouch was using 60+ system ram for some reason for upscale
L
Lytanshade43d ago
No description
C
cocktailpeanut43d ago
good to know when something works
L
Lytanshade43d ago
it's the 1% with issues that check discord and post!
C
cocktailpeanut43d ago
really waiting for a model that works cross platform kind of tired of all this "nvidia only" I am sure even with the existing model, it's just the creator doesn't have the incentive to make them work everywhere which is why I root for companies like Stability, who is fully incentivized to not only make good models but also make sure things work everywhere
L
Lytanshade43d ago
i hit 93GB system ram use with x8 upscale and had to terminate it. something weird going on there. yeah i think cos no money, no one's really keen to put extra effort into open source
C
cocktailpeanut43d ago
from working with the code, my impression was the author really didn't take optimization into account at all, because he probably had other priorities but might improve, saw him keep pushing new updates to the repo
L
Lytanshade43d ago
switching the model from SDXL base to Juggernaut will help i think. i have a comparison thread here: https://www.reddit.com/r/StableDiffusion/comments/1b50sp0/ccsr_vs_supir_upscale_comparison_portrait/ will test vs Pinokio i think the authors just want a little hype and then billion dollar company to buy the code 😆
C
cocktailpeanut43d ago
oh nice, yeah try and let me know. if it's better, could switch
L
Lytanshade43d ago
this stuff is brutal on start-up. uses 45GB RAM and freezes windows for minutes.
No description
L
Lytanshade43d ago
this is where the start sequence goes nuclear
No description
C
cocktailpeanut43d ago
it drops after initialization right?
L
Lytanshade43d ago
yeah:
No description
L
Lytanshade43d ago
something is broken now. using 90GB+ system ram + 12GB VRAM. 3090 isn't going into shared RAM. 1x and 2x upscaling was working fine, 4x and 8x broken freezes sytem and then crashed pinochio so can't capture heh
C
cocktailpeanut43d ago
sounds like something you should report to the supir github repo. if the 1x and 2x work, it means pinokio is doing its job, since all pinokio does is automate the launch was also looking into the code and it was full of weird issues, feels like a lot of it (the parts that are not core to the project) was copy and pasted from other projects. And might be just a matter of changing one line.
L
Lytanshade43d ago
1x and 2x examples here: https://discord.com/channels/1121039057993089076/1215006371268001812/1215156350796169216 oh lol, i'd switched images to a test one they were using it that reddit thred. was 1MB image and without thinking i used without checking dimensions. it was a 2048x3072 image... too used to my 1024x1024 1.3MB gen AI images.
L
Lytanshade43d ago
yeah nothing wrong with x4/x8 . works on an appropriately sized starting image. 201x250 -> 1600x1984
No description
L
Lytanshade43d ago
Shakira needs one of those lint rollers to remove stray hair from her clothing though haha
M
Morpheus43d ago
You tried to 8x upscale a 2k image? 😄 What's that? 16k? 😅 No wonder everything froze. 😁
L
Lytanshade43d ago
yeah. teach me to not check before diving in! i'm so used to checking if image is 1.3MB which is my regular sized SD image vs 3 or 5MB which is an already upscaled one.... explains the 90+GB RAM and poor frozen PC 🙂
M
moony43d ago
I hope they can resolve it soon. It's extremely strange to see that it can't run with 32gb of ram, solely attempting to start the webui.
P
PierrunoYT43d ago
GitHub
It's not working with Pinokio · Issue #67 · Fanghua-Yu/SUPIR
It runs more than 400 seconds and still nothing. It seems it's not working even on 4090
M
Morpheus43d ago
@moonyDid you increase your virtual RAM on windows and try again?
P
Phooney42d ago
Have been looking forward to playing with this and just got it downloaded. 4090 and 64gb RAM handled it OK. I guess I need to play with settings a bit but the defaults aren't totally blowing me away or anything. To be fair, I have barely started testing, but results so far... 1024x1024 --> 2048x2048 in about 2 minutes. Results... not great. Detail not as good as a hires fix with 0.3 denoise, which takes about 4-5 seconds. 2048x2048 --> 2048x2048 also about 2 minutes. Good details added, would classify this as a good result. 2048x2048 --> 4096x4096 after about 2 hours of 100% GPU usage, gave up.
L
Lytanshade42d ago
Yeah. i find it's adding nice details to already great images with 1x.
It's more comparable to Topaz or a traditional upscaler, rather than something like Magnific. Being able to 2x/4x an image and not lose quality is amazing when that's what you need though. I was using Topaz Gigapixel or Affinity for that purpose and Supir seems to be out performing that for me.
And it's amazing for upscaling really bad quality images. i put example here https://discord.com/channels/1121039057993089076/1215006371268001812/1215272009232023595 of a nice 1MP SDXL image next to 2x Supir and can see added skin and hair detail. And more importantly no loss of detail/smearing like you'd often have to work around. looking forward to when/if Supir dev optimizes the code, or people start forking the heck out of it 🙂 AI upscaling is the holy grail for me. having to workflow AI images to something printable in comfyUI is time consuming and not much fun, being able to take a nice 1-shot image and finish it in a local copy of something like Magnific is the future (not quite there_
P
Phooney42d ago
I see you swapped out the sdxl base for juggernaut... seems like a good idea lol. Or dreamshaper perhaps...
L
Lytanshade42d ago
yeah switched to jugger. I wanna test a bunch of my favourite checkpoints too. and merge in detail LoRAs maybe. i've finally gotten thermal pads and paste for my 3090, so going to do that this weekend and dive back in with a vengeance. the screaming fans have put me off doing anything intensive for the last month (summer here)
P
Phooney42d ago
Fellow southern hemispere guy My 4090 doesn't fit in my case, so I had to take the side off... it makes it run way cooler in general, but the whole PC looks like a frankenstein monster because... side off... no 90degree power cables so cables out the side... radiator doesn't fit mounted with the 4090 either... so it's just loose in there. 4090 supported by a zombie figurine... BUT IT WORKS GOD DAMMIT LOL
L
Lytanshade42d ago
be good to it! a 4090 is like rumpelstiltskin slaving away in a dungeon endlessly spinning gold
P
Phooney42d ago
I cherish it... I originally had a 3080ti but it died so I got this 4090 and it's been so good since everything is made for nvidia and with the vram if anything can be run on consumer level gear... it works on this. There's been just mind-bending amounts of new things to play with in the last year
Want results from more Discord servers?
Add your server
More Posts
Trouble with differential-diffusion on Windows 1.2Seems to hang during install.I can’t install it in my MacHi, I have tried to install Pinokio, when I try to open patch.command, the windows stays stuck at "PWhen starting Audiogen I get the nest message:{"message":"python demos\\audiogen_app.py","on":[{"event":"/(http://[0-9.:]+)/","return":"{{event.maStable cascade never startingI Installed Stable cascade everything went fine I tried launching the web UI and it is just loading Forge install hanging on 6/7Microsoft Windows [Version 10.0.22635.3212] (c) Microsoft Corporation. All rights reserved. C:\UserStable Cascade error in mac sonoma 14, How can I fix it???File "/Users/Alisa/pinokio/api/stablecascade.git/app/app.py", line 99, in generate prior_pipelinConnection IssuesSVD is not working ! kindly find the log zip file , I'm looking for your kind support cause till nowDifferential diffusion - Not running on AMD GPUAMD 6700 Win 11 this error just keeps coming up after a few seconds of hitting generate with any imaGLIBCXX_3.4.30' not found : stable diffusionI have this error with stable diffusion and stable diffusion forge , i'm using fedora 39 ######Pinokio - Outdated versionPinokio not running. It's not doing anything at all.Dust3r Installation error/stuckIt always stops at this point and gives me the error. I tried reset and complete reinstall of PinokiPinokio 1.10 crashes instantly after first install attempt - Version 1.20 gives ERROR -> not workingWhat I tried to solve without any good result. 1. Reset Windows 2. Reinstalled only Following Prograwindow opens, just white and nothing else happensHelp. When installing any applications via pinokio 1.1.0, a window opens, just white and nothing els1.2.0 slow start up and weird CPU usageCPU: i5 10600k GPU: 3090 24gb Ram 16gb My 1.2.0 pinokio is taking around 15-20 seconds to start whiDifferential Diffusion won't launchHi! I have 3 suspicious things here: 1. ModuleNotFoundError: No module named 'depth_anything.depthOptimize differential diffusionOptimize differential diffusion for most consumer GPUs My GPU: NVIDIA GeForce GTX 1060 6GB slow ass Melo TTSWhen I tried to test Melo TTS, it throws an error when actually pressing the start button in the graAutomatic1111 installation seems to be stuckI am installing automatic1111 and it does not seam to go past (8/9) shell.run {"message":"webui-userпомогите с проблемойпри установки просит нажать любую клавишу, я нажимаю все клавиши на клавиатуре и мышке но ничего не Fooocus - Outdated driverI have a problem. When ı try to open realistic mod of foocusss, ı get this error : ENOENT: no such f