W
Windmill3mo ago
Eric

How to debug ExecutionErr(only Bun)?

Hi, I just spawn a new windmill instance using docker compose It runs flawlessly except bun script, I checked the log, seems I got a ExecutionErr How can i get more detail log or error to solve this problem? scripts:
// import * as wmill from "windmill-client"

export async function main(x: string) {
return x
}
// import * as wmill from "windmill-client"

export async function main(x: string) {
return x
}
log
windmill_worker-3 | 2024-04-21T13:05:40.719390Z INFO worker:job: windmill-worker/src/common.rs:1118: child process 'bun build' for wk-default-a2270d32b431-P0nVq/018f00c3-2402-d66c-0c20-20c4ac185395 took 861ms, mem_peak: 198176 job_id=018f00c3-2402-d66c-0c20-20c4ac185395 worker=wk-default-a2270d32b431-P0nVq job_id=018f00c3-2402-d66c-0c20-20c4ac185395
windmill_worker-3 | 2024-04-21T13:05:40.719439Z INFO worker:job: windmill-worker/src/worker.rs:3357: finished Bun job 018f00c3-2402-d66c-0c20-20c4ac185395 workspace_id=homelab is_ok=false worker=wk-default-a2270d32b431-P0nVq job_id=018f00c3-2402-d66c-0c20-20c4ac185395
windmill_worker-3 | 2024-04-21T13:05:40.719523Z ERROR worker:completed_job: windmill-queue/src/jobs.rs:422: job 018f00c3-2402-d66c-0c20-20c4ac185395 did not succeed: {"error":{"message":"error during execution of the script:\nprocess terminated by signal: Some(\n 11,\n), stopped_signal: None, core_dumped: true","name":"ExecutionErr"}} worker=wk-default-a2270d32b431-P0nVq job_id=018f00c3-2402-d66c-0c20-20c4ac185395
windmill_worker-3 | 2024-04-21T13:05:40.731878Z INFO worker:completed_job: windmill-queue/src/jobs.rs:685: inserted completed job: 018f00c3-2402-d66c-0c20-20c4ac185395 (success: false) job_id=018f00c3-2402-d66c-0c20-20c4ac185395 root_job="" path="u/zycode277/test" job_kind=Preview started_at="2024-04-21 13:05:39.847252 UTC" duration=876 permissioned_as="u/zycode277" email="zycode277@gmail.com" created_by="zycode277" is_flow_step=false language=Some(Bun) success=false worker=wk-default-a2270d32b431-P0nVq job_id=018f00c3-2402-d66c-0c20-20c4ac185395
windmill_worker-3 | 2024-04-21T13:05:40.719390Z INFO worker:job: windmill-worker/src/common.rs:1118: child process 'bun build' for wk-default-a2270d32b431-P0nVq/018f00c3-2402-d66c-0c20-20c4ac185395 took 861ms, mem_peak: 198176 job_id=018f00c3-2402-d66c-0c20-20c4ac185395 worker=wk-default-a2270d32b431-P0nVq job_id=018f00c3-2402-d66c-0c20-20c4ac185395
windmill_worker-3 | 2024-04-21T13:05:40.719439Z INFO worker:job: windmill-worker/src/worker.rs:3357: finished Bun job 018f00c3-2402-d66c-0c20-20c4ac185395 workspace_id=homelab is_ok=false worker=wk-default-a2270d32b431-P0nVq job_id=018f00c3-2402-d66c-0c20-20c4ac185395
windmill_worker-3 | 2024-04-21T13:05:40.719523Z ERROR worker:completed_job: windmill-queue/src/jobs.rs:422: job 018f00c3-2402-d66c-0c20-20c4ac185395 did not succeed: {"error":{"message":"error during execution of the script:\nprocess terminated by signal: Some(\n 11,\n), stopped_signal: None, core_dumped: true","name":"ExecutionErr"}} worker=wk-default-a2270d32b431-P0nVq job_id=018f00c3-2402-d66c-0c20-20c4ac185395
windmill_worker-3 | 2024-04-21T13:05:40.731878Z INFO worker:completed_job: windmill-queue/src/jobs.rs:685: inserted completed job: 018f00c3-2402-d66c-0c20-20c4ac185395 (success: false) job_id=018f00c3-2402-d66c-0c20-20c4ac185395 root_job="" path="u/zycode277/test" job_kind=Preview started_at="2024-04-21 13:05:39.847252 UTC" duration=876 permissioned_as="u/zycode277" email="zycode277@gmail.com" created_by="zycode277" is_flow_step=false language=Some(Bun) success=false worker=wk-default-a2270d32b431-P0nVq job_id=018f00c3-2402-d66c-0c20-20c4ac185395
No description
4 Replies
Eric
Eric3mo ago
I tested other runtime using the default script, it all ok except bun
No description
rubenf
rubenf3mo ago
It's a SIGSEGV, which is strange. I can't reproduce on a vanilla docker, so maybe you're on a specific setup
Eric
Eric3mo ago
I replaced caddy with traefik and use external postgress database (followed the install documentation) Any debug option that I can get more detail?
rubenf
rubenf3mo ago
What's the os you're running docker on ? I would try to run the bun image directly to see if you can reproduce Ideally using the same version as our dockerfile If you can reproduce, I would ask on the bun discord But can confirm to you on linux and using docker and containerd you do not have such issue