create-solid messed up peer dependencies

Upon creation I've got this warning
 WARN  Issues with peer dependencies found
.
├─┬ solid-start-node 0.2.22
│ └─┬ @rollup/plugin-node-resolve 13.3.0
│ ├── ✕ unmet peer rollup@^2.42.0: found 3.18.0 in solid-start-node
│ └─┬ @rollup/pluginutils 3.1.0
│ └── ✕ unmet peer rollup@^1.20.0||^2.0.0: found 3.18.0 in solid-start-node
└─┬ solid-start 0.2.22
└── ✕ unmet peer vite@^3.1.8: found 4.1.4
 WARN  Issues with peer dependencies found
.
├─┬ solid-start-node 0.2.22
│ └─┬ @rollup/plugin-node-resolve 13.3.0
│ ├── ✕ unmet peer rollup@^2.42.0: found 3.18.0 in solid-start-node
│ └─┬ @rollup/pluginutils 3.1.0
│ └── ✕ unmet peer rollup@^1.20.0||^2.0.0: found 3.18.0 in solid-start-node
└─┬ solid-start 0.2.22
└── ✕ unmet peer vite@^3.1.8: found 4.1.4
Why trying to run it throw right away
solid-start dev
version 0.2.22
failed to load config from ~/dev/personal/organizzer/vite.config.ts
node:internal/process/promises:288
triggerUncaughtException(err, true /* fromPromise */);
^

Error [ERR_MODULE_NOT_FOUND]: Cannot find module '~/dev/personal/organizzer/node_modules/.pnpm/vite-plugin-solid@2.6.0_solid-js@1.6.11+vite@3.2.5/node_modules/solid-refresh/babel' imported from ~/dev/personal/organizzer/node_modules/.pnpm/vite-plugin-solid@2.6.0_solid-js@1.6.11+vite@3.2.5/node_modules/vite-plugin-solid/dist/esm/index.mjs
Did you mean to import solid-refresh@0.4.3_solid-js@1.6.11/node_modules/solid-refresh/babel.js?
at new NodeError (node:internal/errors:393:5)
at finalizeResolution (node:internal/modules/esm/resolve:323:11)
at moduleResolve (node:internal/modules/esm/resolve:916:10)
at defaultResolve (node:internal/modules/esm/resolve:1124:11)
at nextResolve (node:internal/modules/esm/loader:163:28)
at ESMLoader.resolve (node:internal/modules/esm/loader:841:30)
at ESMLoader.getModuleJob (node:internal/modules/esm/loader:424:18)
at ModuleWrap.<anonymous> (node:internal/modules/esm/module_job:76:40)
at link (node:internal/modules/esm/module_job:75:36) {
code: 'ERR_MODULE_NOT_FOUND'
}
solid-start dev
version 0.2.22
failed to load config from ~/dev/personal/organizzer/vite.config.ts
node:internal/process/promises:288
triggerUncaughtException(err, true /* fromPromise */);
^

Error [ERR_MODULE_NOT_FOUND]: Cannot find module '~/dev/personal/organizzer/node_modules/.pnpm/vite-plugin-solid@2.6.0_solid-js@1.6.11+vite@3.2.5/node_modules/solid-refresh/babel' imported from ~/dev/personal/organizzer/node_modules/.pnpm/vite-plugin-solid@2.6.0_solid-js@1.6.11+vite@3.2.5/node_modules/vite-plugin-solid/dist/esm/index.mjs
Did you mean to import solid-refresh@0.4.3_solid-js@1.6.11/node_modules/solid-refresh/babel.js?
at new NodeError (node:internal/errors:393:5)
at finalizeResolution (node:internal/modules/esm/resolve:323:11)
at moduleResolve (node:internal/modules/esm/resolve:916:10)
at defaultResolve (node:internal/modules/esm/resolve:1124:11)
at nextResolve (node:internal/modules/esm/loader:163:28)
at ESMLoader.resolve (node:internal/modules/esm/loader:841:30)
at ESMLoader.getModuleJob (node:internal/modules/esm/loader:424:18)
at ModuleWrap.<anonymous> (node:internal/modules/esm/module_job:76:40)
at link (node:internal/modules/esm/module_job:75:36) {
code: 'ERR_MODULE_NOT_FOUND'
}
3 Replies
edygar
edygar2y ago
Is there a quick workaround to the issue for now? like pointing to an older version or something?
lxsmnsyc
lxsmnsyc2y ago
tweaking solid-refresh' version in the lockfile which should be 0.5.0
Want results from more Discord servers?
Add your server
More Posts