Why is drizzle-zod converting a string to enum?

CCory4/14/2023
It seems like it is converting mysql text() or varchar to enums<unknown>?
CCory4/14/2023
Bbloberenober4/15/2023
looks broken will look into it did you update drizzle-orm and drizzle-zod to latest?
CCory4/17/2023
I didn’t update drizzle-orm - will try that This seems to get better once I restarted VScode and updated drizzle

Looking for more? Join the community!

Want results from more Discord servers?
Add your server
Recommended Posts
how to do ANYneed to do `where 'myvariable' = ANY(mycolumn)`[BUG?] Postgres transactions throwing connection timeouts after a lot of queriesI think there's a syntax error in Postgres transactions ----> see screenshot cc: @bloberenoberUnique Key SchemaI am trying to create an unique key on a table using a custom schema, the generated sql migration fisqliteTable wrapper which modifies fields, with proper typesMore of a TypeScript question, but I'm trying to create a wrapper for sqliteTable to add a set of stHow to count joined table?I'm trying to count rows returned by join for a query, basically the same as this: https://dba.stackConfig in Typescript?Hello, after upgrading drizzle-kit to 0.17.4 my `drizzle.config.ts` file stopped working. Is it now Problem running a migrationHello there, I'm currently facing an issue with a database migration. I have two simple tables definHow do I connect to sqlite on fly.io?I followed the instructions on fly.io on how to setup a project using sqlite. I believe I did it allEnumsCan pgEnum be converted to zod enums?Typescript build fails with large number of columnsI have a table with ~460 columns, and on trying to run typescript on my app, I'm getting "error TS25many-to-one transactionHello, I want to create transaction involving arbitrary number of inserts. For example, Artist (one[BUG] drizzle-kit doesn't like imports outside of a module`npx drizzle-kit generate:pg drizzle-kit: v0.17.4 drizzle-orm: v0.23.10 C:\Users\Abdul\Documents\Gidrizzle-kit throwing await is not available in the configured target environmentHi, when using the generate:pg command i am getting this error: **'Top-level await is not available [Bug] Postgres migrations are broken on 0.23.10Re-running the same postgres migration twice just throws an error that a particular table already ex