Distance Horizon compatibility issue

Hi, I am currently using Minecraft Java Edition v1.20.4 I put DistantHorizons-fabric-2.0.2-a-dev-1.20.4.jar into my mod folder and I'm getting incompatibility message on the console. It's the correct verision number and I crosschecked everything. Does anyone know what the problem could be? Thanks.
Solution:
That message is normal
Jump to solution
5 Replies
comy
comy4mo ago
No description
comy
comy4mo ago
No description
Solution
Steveplays
Steveplays4mo ago
That message is normal
comy
comy4mo ago
Oh thanks.
Steveplays
Steveplays4mo ago
No problem. I'm not sure if it appears in releases as well currently, but if you compile it yourself then it definitely appears