BSL shaders not working with DH mod

please help
No description
72 Replies
lalala
lalala4mo ago
having same problem pls help
boo
boo4mo ago
We are using Iris (not optifine)
TheNewSky
TheNewSky4mo ago
1.7?
boo
boo4mo ago
1.20.4 using the nightly.build
TheNewSky
TheNewSky4mo ago
are you using iris 1.7
boo
boo4mo ago
oh sorry
TheNewSky
TheNewSky4mo ago
or did you just download it from modrinth
boo
boo4mo ago
iris-mc1.20.4-1.6.17 yueah I think so
TheNewSky
TheNewSky4mo ago
You need the 1.7 beta from the iris discord server
boo
boo4mo ago
do you have an invite link please or the github.link preferred
boo
boo4mo ago
ok, just installed these two:
No description
boo
boo4mo ago
will test now
TheNewSky
TheNewSky4mo ago
That says that's the version for the 1.20.5 snapshot one sec
boo
boo4mo ago
No description
boo
boo4mo ago
okk
TheNewSky
TheNewSky4mo ago
If you want I can send the direct link to the 1.20.4 download I'm not sure how you'd download it from the github page but the link's on the iris server
boo
boo4mo ago
I think I got it, 1 sec
boo
boo4mo ago
No description
boo
boo4mo ago
these three?
TheNewSky
TheNewSky4mo ago
Looks right
boo
boo4mo ago
No description
boo
boo4mo ago
game crash
TheNewSky
TheNewSky4mo ago
I might be wrong I think I saw someone say they made 1.7 compatible with only distant horizons 2.0.3 for some reason
boo
boo4mo ago
No description
boo
boo4mo ago
these are the mods I have rn highlighted the important ones ( i think ) most of them are from fabulously optimized
TheNewSky
TheNewSky4mo ago
I think it's because you're using distant horizons 2.0.2 and not 2.0.3 i just tested it and i get the same crash with the new iris version using 2.0.2 but it works with 2.0.3 not sure why they would do that If you don't want to use 2.0.3 I can send the older version of iris 1.7 I have
boo
boo4mo ago
ah, how do I get 2.0.3
TheNewSky
TheNewSky4mo ago
How'd you download the iris 1.7? in the link from the server it comes with 2.0.3 in a zip
boo
boo4mo ago
this is how I got DH 2.0.2
No description
boo
boo4mo ago
#links-n-downloads
TheNewSky
TheNewSky4mo ago
I can't find the 2.0.3 download in the server anywhere lol
boo
boo4mo ago
2.0.2* sorry
TheNewSky
TheNewSky4mo ago
ik you need 2.0.3 and I had thought it was in this server but I can't find it anywhere
boo
boo4mo ago
TheNewSky
TheNewSky4mo ago
Ah yes in announcements of course
boo
boo4mo ago
No description
TheNewSky
TheNewSky4mo ago
btw be careful when opening a world that has LODs that were generated with 2.0.2
boo
boo4mo ago
new crash
TheNewSky
TheNewSky4mo ago
I think it's just easier if you use the download from the iris server lol https://github.com/IrisShaders/Iris-Installer-Files/releases/latest/download/Iris-Sodium-Beta-1.20.4.zip It's a zip folder with DH and iris in it
boo
boo4mo ago
okay I got it, can I ask what to do with it? I checked the file.names and everything matched
TheNewSky
TheNewSky4mo ago
Just open it and the mods should be in there
boo
boo4mo ago
still crash
TheNewSky
TheNewSky4mo ago
what's the crash look like now the -1 exit code?
boo
boo4mo ago
No description
boo
boo4mo ago
sanme thing
TheNewSky
TheNewSky4mo ago
replace the version of iris you have with the one from the download im not sure what version of iris you have but distant horizons is incompatible with it for whatever reason
boo
boo4mo ago
No description
boo
boo4mo ago
yeah, that's the only file.name that didn't match but even after I replaced it gives same crash message
boo
boo4mo ago
No description
TheNewSky
TheNewSky4mo ago
And you're using the version of distant horizons from the download link too?
boo
boo4mo ago
No description
TheNewSky
TheNewSky4mo ago
what happened
boo
boo4mo ago
No description
boo
boo4mo ago
i tried replace all and i think i messed wit hthe mod folder now i dont see sodium anymore or fabric
TheNewSky
TheNewSky4mo ago
how'd that happen
boo
boo4mo ago
wait this is fixable
TheNewSky
TheNewSky4mo ago
just redownload fabric api and sodium not sure why it's saying fabric as a whole is missing tho
boo
boo4mo ago
okay
boo
boo4mo ago
No description
boo
boo4mo ago
now it's exit code: -1
TheNewSky
TheNewSky4mo ago
I think you're missing iris 1.7 although im not sure if that would be the cause of the crash I don't see it in your mods folder anymore
boo
boo4mo ago
sorry I
boo
boo4mo ago
this is updated mods folder:
No description
TheNewSky
TheNewSky4mo ago
After all that one of those mods might be incompatible 🙃 Try running with just distant horizons, iris, sodium, indium, and fabric api to make sure
boo
boo4mo ago
ok it work yeah :(
TheNewSky
TheNewSky4mo ago
Do you want me to send the older version of iris I have so you can use distant horizons 2.0.2 wait nvm 😦 I have 1.20.1
boo
boo4mo ago
its ok you can check their discord server
TheNewSky
TheNewSky4mo ago
Yea but idk how to get the older versions which work with 2..02 since the link just downloads the latest version So idk if it's possible to get an older version of iris 1.7 for 1.20.4 You'll just have to remove mods until it works
boo
boo4mo ago
yeee okay
TheNewSky
TheNewSky4mo ago
You can try a binary search /binarysearch
YAGPDB.xyz
YAGPDB.xyz4mo ago
Try a binary search and figure out which mod is causing it. So disable half of the mods, see if issue is still there, if yes disable half again etc etc until you find the mod that's causing the issue.
Tenor
boo
boo4mo ago
that was what i was gonna do xd thjank you