Klipper fails after hard Recovery

Hey all, After clicking hard recovery for klipper on Mainsail, Klipper won´t run again (Section 'ratos_homing' is not a valid config section). I´ve seen the help article (https://os.ratrig.com/docs/troubleshooting/) but can´t follw the steps. When using it´s IP/configure I get "error 502 Bad Gateway". RatOs.Local/configure was broken on my machine since I got it. Starting it without internet connection wont help - same problem there when trying to configure the machine. Is there any way to get around this issue (hopefully excluding a complete reinstall)? Thanks a lot!
Troubleshooting | RatOS
My steppers are running backwards!
Solution:
When trying to reach that page. Afterall I did two full reinstalls. After the first one I made all the Updates and ran into the same problem. On the second try I left out the Klipper and RatOS Updates and waited for new releases before updating. Not a satisfying solution, but worked for me and narrowed the origin of the error down ^^...
Jump to solution
3 Replies
captain.fpv
captain.fpv5w ago
I AM GETTING THE SAME ERROR
TheTik
TheTik5w ago
When using it´s IP/configure I get "error 502 Bad Gateway"
That's when you just try to reach that page, or after you press "Symlink klippy extensions"?
Solution
AllSparkII
AllSparkII4w ago
When trying to reach that page. Afterall I did two full reinstalls. After the first one I made all the Updates and ran into the same problem. On the second try I left out the Klipper and RatOS Updates and waited for new releases before updating. Not a satisfying solution, but worked for me and narrowed the origin of the error down ^^