`rpm-ostree status`

rpm-ostree status
33 Replies
Rumble
Rumble2mo ago
[kyle@bazzite ~]$ rpm-ostree status State: idle Deployments: ● ostree-image-signed:docker://ghcr.io/ublue-os/bazzite-deck:stable Digest: sha256:a08c542ed755d55ce02d062f7bc43e1cba6c7e44f16b6db05c67f2de63755af2 Version: main (2024-04-24T17:03:19Z) LayeredPackages: sunshine LocalPackages: lact-0.5.4-0.x86_64 ostree-image-signed:docker://ghcr.io/ublue-os/bazzite-deck:stable Digest: sha256:f87d5dd11724f35cf8f47a1d22e38777d22160412737ad8d8a288fe23758eb1d Version: 39.20240419.0 (2024-04-19T17:09:55Z) LayeredPackages: sunshine LocalPackages: lact-0.5.3-0.x86_64
tryhardsoccermomswag
ok that's completely vanilla wow someone else with a HTPC seemed to have a different issue but were able to get in gaming mod
Rumble
Rumble2mo ago
hmm. Now when I'm rebooting the PC its booting directly to game mode so I'm not even sure how to get back to desktop lol
tryhardsoccermomswag
steam menu > power > switch to desktop mode
Rumble
Rumble2mo ago
I can't get to steam menu its just a totally black screen
tryhardsoccermomswag
Oh right i thought it wasnt booting at all have you done anything with it i know no packages were layered
Rumble
Rumble2mo ago
No it boots... it shows the tiny bazzite logo, shows the spinner, then black
tryhardsoccermomswag
but any ujust commands? or gamescope config edits
Rumble
Rumble2mo ago
I don't think so
tryhardsoccermomswag
i guess for now rpm-ostree rollback oh wait you can't get to desktop you can still get into a TTY Ctrl+Alt+F4
Rumble
Rumble2mo ago
yeah I've jsut been using ssh from my work pc
tryhardsoccermomswag
or that that works too i guess rolling back until this can be figured out is the best option for you instead of reinstalling. this is a weird issue it's solely with steam gaming mode too since the desktop worked
Rumble
Rumble2mo ago
yeah desktop seemed to work fine. I guess it boots into desktop once after an update maybe?
tryhardsoccermomswag
it shouldnt -deck images should boot directly into gaming mode regardless of an update or not
Rumble
Rumble2mo ago
odd then I really don't know appreciate your help. If theres anything I can clarify to help test let me know
tryhardsoccermomswag
probably one more thing for hardware i guess ujust device-info and paste the link here that's about all i got, im aware it's an AMD HTPC setup
Rumble
Rumble2mo ago
cool its rebooting, then ill send
tryhardsoccermomswag
ok thanks
Rumble
Rumble2mo ago
here you go https://paste.centos.org/view/80ae929f booted up just fine after the rollback 😄
tryhardsoccermomswag
thanks
journalctl -b | fpaste
journalctl -b | fpaste
Wispirr
Wispirr2mo ago
Since I'm encountering a similar problem where I can't get into the Steam gaming mode, here's my ujust device-info: https://paste.centos.org/view/777cfbb9
tryhardsoccermomswag
@Rumble @Wispirr were you on :testing or :stable
Rumble
Rumble2mo ago
Stable
tryhardsoccermomswag
ok thanks
Wispirr
Wispirr2mo ago
Stable for me too
tryhardsoccermomswag
@Wispirr @Rumble try to rebase to :testing see if anything changes
Rumble
Rumble5w ago
I'll likely not be able to try until tomorrow. Will do tho and report back.
tryhardsoccermomswag
that is ok letting everyone know who had an issue
Rumble
Rumble5w ago
thanks for keeping us in the loop!
Wispirr
Wispirr5w ago
Just rebased to bazzite-deck:testing, sadly it still can't launch game mode 😢 My rpm-ostree status: State: idle Deployments: ● ostree-image-signed:docker://ghcr.io/ublue-os/bazzite-deck:testing Digest: sha256:4561fa387464f7e5c6f71f416c1d094a9804c4638d4b4232b164703b77c7bf45 Version: testing (2024-04-26T01:20:34Z) LayeredPackages: s-tui Initramfs: '"-I /etc/crypttab /etc/modprobe.d/amdgpu.conf /etc/modprobe.d/deck-blacklist.conf" ' ostree-image-signed:docker://ghcr.io/ublue-os/bazzite-deck:39-20240407 Digest: sha256:8aa518ddc217a916ff1524621254462a4e45645853ffd235cbeb63bb9e76c990 Version: 39.20240406.0 (2024-04-07T01:31:36Z) LayeredPackages: s-tui Initramfs: '"-I /etc/crypttab /etc/modprobe.d/amdgpu.conf /etc/modprobe.d/deck-blacklist.conf" ' My journalctl -b if it helps: https://paste.centos.org/view/7f7256fe
Rumble
Rumble5w ago
just tried mine now. No better on testing than it was before. Same instant crash back to desktop