Lag Spikes

Recently, from about Minecraft version 1.19.3 until now I have had lag spikes in both single-player and multi-player. Just a few minutes of playing and my fps suddenly drops from around 30-40(my fps with most shaders) to 2. It goes back up to the stable fps it was at before after about 15 seconds, and this process continues on and on. Even without shaders, this lag spike still happens. These lag spikes slow my entire computer, and if I try pausing the game and moving my mouse, it also lags, meaning that my system slows as a whole. Allocating more RAM delays this process, but it still happens. This never happened before 1.19.3, and when I try Optifine, it works perfectly without any lag spikes, but obviously, with a lower frame rate. I have an RTX 3050 and an Intel Core i7. I'm unsure if this is a problem with my settings, graphics card, or sodium. In the attached video I am using Complementary Unbound.
15 Replies
Slooshie
Slooshie3mo ago
Try reinstalling your graphics drivers with DDU
Hems ♢
Hems ♢3mo ago
why do u have 2gb of ram in it Minecraft with some mods and shaders atleast needs 4gb of ram 6-8 if it's a heavy modpack try installing sodium extras and enable culling, i kinda had the same problem and when i was messing around, disabling culling settings caused a huge fps drop
TheNewSky
TheNewSky3mo ago
They said it still happens when allocating more ram it just takes longer for it to happen If it happens when memory runs out and the gc runs then I’d imagine it’s related to cpu, memory (somehow), or something like your install of Java
Hems ♢
Hems ♢3mo ago
something related to java then
Slooshie
Slooshie3mo ago
if they're constantly running out of RAM, causing these lagspikes, then maybe they should look into gettings some mods like FerriteCore and Memory Leak Fix
Modrinth
FerriteCore - Minecraft Mod
Memory usage optimizations
Modrinth
Memory Leak Fix - Minecraft Mod
A mod that fixes random memory leaks for both the client and server
Zztop5
Zztop53mo ago
Thanks, will try. Normally, I use 4GB of ram btw. I applied both mods and played for about 20-30 minutes and it seems to have done the job. Should I also try using DDU?
Slooshie
Slooshie3mo ago
if the problem is fixed, no
Zztop5
Zztop53mo ago
I logged back in and the issue started back up again. I even noticed my computer suddenly slowed for a few seconds when I was in the launcher.
Hems ♢
Hems ♢3mo ago
have u tried modernfix nvm it's not even available on 1.19.3
Zztop5
Zztop53mo ago
I could try it, because I now play on the latest version, 1.20.4. Thanks for the tip.
hardester
hardester3mo ago
Few things I like to point out, you're on a laptop. What is your CPU temperature looking like? Any battery saving profiles enabled?
Zztop5
Zztop52mo ago
@hardester I haven't checked my CPU temp but it seems that it runs better on my lap when I was testing if temperature affects it. I'm thinking about buying a laptop stand to fix overheating. I also enabled GeForce Battery Boost 2.0.
hardester
hardester2mo ago
:linus: Your poor laptop is undoubtedly overheating if that's the case...
Zztop5
Zztop52mo ago
Ya...I've been looking for a stand for a few weeks but have a 17-inch laptop. It's hard to find a lower stand where I don't have to buy an external keyboard. Would turning off the battery boost also help?
TheNewSky
TheNewSky2mo ago
Try cleaning any dust buildup out of the fans too