world unplayable after running 2.0.3

if a world is loaded in DH 2.0.3, then ran later with 2.0.2, its unplayable. it crashes your game. ive tried a few methods like deleting files related to dh in my world folder, nothing worked. im using the latest build provided by the iris installer, as of 4/22. crash log: https://mclo.gs/WnscMMZ (modrinth)
mclo.gs
Fabric 1.20.4 Server Log [#WnscMMZ]
2665 lines | 269 errors
No description
Solution:
2.0.3 LODs do not work on 2.0.2
Jump to solution
11 Replies
Piotr Barcz YT
Piotr Barcz YT2mo ago
Yeah, that's to be expected considering that these are alpha builds and will break stuff
hardester
hardester2mo ago
Since this is Distant Horizons specific issue, try asking in the Distant Horizons Discord server instead. That or one of the staff members of DH in here might help...
That Guy
That Guy2mo ago
This has been mentioned and they have suggested to backup your worlds before updating
Lgnd
Lgnd2mo ago
2 0 3 has basically different lod format, old version just doesnt understand it
havoc
havoc2mo ago
i gotcha, thanks for clarifying
Katerang31 ϟϟ
Katerang31 ϟϟ2mo ago
use iris 1.6.17 try it at least
Slooshie
Slooshie2mo ago
you don't know what you're talking about, and this was already solved
Solution
Slooshie
Slooshie2mo ago
2.0.3 LODs do not work on 2.0.2
Arphex
Arphex2mo ago
Use latest DH commit (18859d22) and latest version of Iris (1.7). it should works. And make sure to delete DistantHorizons.sqlite file inside your world/data folder for offline worlds and the folder Distant_Horizons_server_data for online worlds. https://gitlab.com/jeseibel/distant-horizons/-/jobs/6676128976/artifacts/download https://cdn.modrinth.com/data/YL57xq9U/versions/45ETshvT/iris-1.7.0%2Bmc1.20.4.jar
hardester
hardester2mo ago
:linus: I like how you give direct download link to the Iris download on Modrinth.
Arphex
Arphex2mo ago
It's sarcastic? 😆