Versions 1.20.1 requiring Fabric loader 1.20.2?

Hi. I had a build of Distant Horizons 1.20.1 before its official release in December that was iffy, but I wanted to download the alpha release of it today. I went to install it (tried off of curseforge and another reputable site, don't remember the name off the top of my head) but now it is tellling me it requires me to be playing 1.20.2. To clarify, I am 100% using a 1.20.1 Fabric mod loader, and I am 100% downloading the correct 1.20.1 version of the mod. Any ideas? I attached some screenshots.
No description
No description
6 Replies
majo24
majo243mo ago
If you want an in developement version, get it from here https://discord.com/channels/881614130614767666/882038774861819954.
Discord
Discord - A New Way to Chat with Friends & Communities
Discord is the easiest way to communicate over voice, video, and text. Chat, hang out, and stay close with your friends and communities.
Humphrey38194
Humphrey381943mo ago
The modrinth and curseforge downloads for 1.20.1 are giving me the above error message I wanted a more stable version and I'm unsure as to why the error message is telling me I need 1.20.2
TheNewSky
TheNewSky3mo ago
Are you putting it in the wrong folder
Humphrey38194
Humphrey381943mo ago
No, its in the same folder as the rest of my mods (all client-side)
TheNewSky
TheNewSky3mo ago
I mean like the wrong instance If you have multiple
Humphrey38194
Humphrey381943mo ago
I don't think so, but let me double check really quick just in case That seems to have been the issue, thank you for the help!
Want results from more Discord servers?
Add your server
More Posts
Problems with OculusDoes this mod works with Oculus + Bliss Shaders? Also I need to know how to check whether the mod isImplementation limit of 16 active fragment shader samplers - fragment shader uses 19 samplersIF YOU GET THIS ERROR - Switch from BLISS shader to BSL if you're on mac `Implementation limit of 16Ad Astra oil LOD textureMinecraft: 1.20.1 Forge: 47.2.30 DH: Latest build (13 May) Ad Astra: 1.15.18 (Not really a bug, butError message "Batch World Generator: 0:5@c[-260,-424](FEATURES) timed out and terminated!"cant seem to find a solution to this in faq running version 1.19.2 with 12gb ram allocated, lod renUgly section where water meets LODsIs there any way I can get rid of the obvious and ugly looking section as shown in my screenshot? ItAfter Installing DH together with Iris+Fabric and not having any launch errors DH options wont showI installed Iris+Fabric 1.20.4 together with the DH beta mod (From the Iris Installer option), on laDistant Generation HelpHow do I get distant horizons to load chunks further out? Do I have to have visited that chunk beforLatest DH in a custom modpackCurrently the custom modpack I've been working on is finished but potential issues could arise as I change DH to RC from DEV in laptop but got worse performancehi guys, anybody knows why i get worse fps after i change the DH version to RC from dev? it make noTrying to get Bliss to work with DHHello! So I'm new back to modded minecraft so I apologize if this is already somewhere but i couldn'