LOD Chunks aren't loading?

And before you tell me to read the faq, I did. I did multiple times. I've done what it told me to do. I'm running Minecraft 1.20.4, I've not been getting any error messages, and I'm not using any shaders. I'm in a single player world, and for some reason today the mod just decided to stop working and I am unsure why. I was completely fine yesterday when I was using it, I was using bliss shaders and a couple of qol mods and a resource pack and everything was working fine. I attempted this morning to update all my mods, including DH, to 1.20.6 and run that, but I realized that a couple of my mods were incompatible so I went back to 1.20.4, and since then the mod hasn't been working at all. I have restarted my computer, reinstalled the mod, reinstalled fabric, reinstalled minecraft entirely, and nothing has worked so far. Any ideas?
36 Replies
MarijnIsN00B
MarijnIsN00B2mo ago
Try deleting your DH config and reinstalling the mod
j^squared
j^squared2mo ago
I have tried that as well.
MarijnIsN00B
MarijnIsN00B2mo ago
Have you tried just completely whiping your .minecraft folder too? Not a great solution but in this case its all I can think of And remember to back it up just in case
j^squared
j^squared2mo ago
Yep, that’s what I did when I reinstalled. I deleted the launcher and completely deleted my .minecraft folder
j^squared
j^squared2mo ago
After reinstalling everything the mod still wouldn’t work. There was also occasionally times where the game would break if I adjusted the rending distance setting in game. Similar to this screenshot I saw in another thread
No description
MarijnIsN00B
MarijnIsN00B2mo ago
Could you share your specs, logs, screenshots, DH version and any other relevant info?
j^squared
j^squared2mo ago
version
No description
j^squared
j^squared2mo ago
here are some screenshots I took with the mod active, at least it said it was according to the settings
No description
No description
j^squared
j^squared2mo ago
im not sure if those screen shots are very helpful but Im not sure what else to provide for screenshots
j^squared
j^squared2mo ago
here is the "latest log file" that i have
j^squared
j^squared2mo ago
im running a ryzen 5 3400g and an nvidia 2060 super and 16 gigs of ram i usually run the mod with a 128 render distance, med preset with low impact on cpu
Miki_P98
Miki_P982mo ago
For this change the quality preset to medium or higher, and set transparency to compleate
j^squared
j^squared2mo ago
I do have both of those settings on that, and I also haven’t been noticing that weird bug as much or at all but the actual lod chunks haven’t been loading all together so I’m not sure
Miki_P98
Miki_P982mo ago
/slowgen
YAGPDB.xyz
YAGPDB.xyz2mo ago
If it feels like LoD generation with Distant Generator is too slow: Try increasing CPU Load in Distant Horizons settings for faster generation, but you will experience more lag spikes and stuttering due to heavier workload on CPU. To see if Distant Generator is really working or not: 1) Check CPU usage while in-game, using Aggressive settings of CPU Load. If CPU usage's hovering around 80-100%, the LoDs are generating in the background. 2) Go to DH settings > Advanced Options > Debug > Wireframe, set Enable Debug Wireframe Rendering and Show World Gen Queue to True. Enabling both settings will show you the visualization of world gen tasks queued and working on the map (blue boxes for queued tasks, red boxes for working tasks)
Miki_P98
Miki_P982mo ago
Have you tried the second part?
j^squared
j^squared2mo ago
No I have not, I will try that in a bit once I finish making my lunch
j^squared
j^squared2mo ago
I attempted enabling the wireframe option and im now getting this weird line on my screen. the second screenshot is when i turned on render debug, not sure if its useful but it kept repeating that same dialogue over and over. the last screenshot is of when i turned on only load LOD chunks, showing it doesn't load them
No description
No description
No description
j^squared
j^squared2mo ago
i didnt see an option saying anything about world gen queue
TheNewSky
TheNewSky2mo ago
Pretty sure the world gen queue is in the f3 menu on the right
Puhpine
Puhpine2mo ago
if you delete the config file at .minecraft/config/distanthorizons.toml all your debugging settings will be reset to default (off)
YAGPDB.xyz
YAGPDB.xyz2mo ago
To edit the config, press the button next to the FOV slider to edit the config. The config file found in .minecraft/config/DistantHorizons.toml
j^squared
j^squared2mo ago
hold on, im not entirely sure what happened. after turning the debug tools off and on again, it appears to have loaded some lod chunks, and it seems like the chunks are just taking a really really really long time to load. the first screen shot shows one direction, and then i turned around to show where i came from and it appears the lod chunks have loaded. i was definitely not having this issue before but it seems like the issue is different than what i originally thought
No description
No description
j^squared
j^squared2mo ago
that or they're not loading until i walk through them because the chunks that should've loaded in the first ss still have yet to load
Miki_P98
Miki_P982mo ago
Are you on a server?
j^squared
j^squared2mo ago
nope this is a single player world i can tell now that they are just loading very very slowly, and i would usually just chalk it up to a performance issue because im computer isnt necessarily a beast, but i wasnt having these issues before at all so im not sure what happened
j^squared
j^squared2mo ago
it has loaded now, a bit more than before, but it took what 3 minutes to load all of that?
No description
Miki_P98
Miki_P982mo ago
is distant generation enabled in the settings?
j^squared
j^squared2mo ago
yes
Miki_P98
Miki_P982mo ago
- disable it - restart the game - enable it back
j^squared
j^squared2mo ago
alright The generation is still a little slow but its definitely better than it was before. Thank you for your help, I think its working better now.
Miki_P98
Miki_P982mo ago
If you want to speed it up use mods: - Noisium - Faster Random - Lithium (fabric) There are couple others, these are the most important ones
j^squared
j^squared2mo ago
can i use all three of these mods at the same time?
Miki_P98
Miki_P982mo ago
yes
j^squared
j^squared2mo ago
k, js wanted to make sure
Miki_P98
Miki_P982mo ago
GitHub
UsefulMods/Performance at main · TheUsefulLists/UsefulMods
Just a list of useful mods. Contribute to TheUsefulLists/UsefulMods development by creating an account on GitHub.