LOD not showing up?

Hey, I have the problem that chunks dont properly render, which causes this mod to be barerly better than just running it with the native render distance. Any suggestions? :)
No description
Solution:
try deleting your /config
Jump to solution
62 Replies
Shayn-Keta
Shayn-Keta4w ago
on top of that it caused for some weird lighting issues in certain chunks
No description
Miki_P98
Miki_P984w ago
/logstored
YAGPDB.xyz
YAGPDB.xyz4w ago
You should send your latest.log file to provide additional useful information. Logs are located in the .minecraft/logs directory. On Windows: %appdata%\.minecraft\logs On Linux: ~/.minecraft/logs On Mac: ~/Library/Application Support/minecraft/logs Please upload the file to mclo.gs instead of sending the raw file. This makes reading the contents of the file a lot easier and improves the chances of you getting the help needed. After uploading the file, click on Save and send the link.
Shayn-Keta
Shayn-Keta4w ago
i think it works like this? Let me know if I uploaded it wrong
Miki_P98
Miki_P984w ago
I think it is good I don't see the modlist in the log, can you send it separately? It can be a written list or a set or screenshots
Shayn-Keta
Shayn-Keta4w ago
ofc!
No description
Solution
Miki_P98
Miki_P984w ago
try deleting your /config
YAGPDB.xyz
YAGPDB.xyz4w ago
To edit the config, press the button next to the FOV slider to edit the config. The config file found in .minecraft/config/DistantHorizons.toml
Miki_P98
Miki_P984w ago
Note that this will reset your DH settings!!! So you can backup it first!
Shayn-Keta
Shayn-Keta4w ago
will it reset all my settings :0 oh yeah i see what u mean deleting the config folder
Miki_P98
Miki_P984w ago
not the folder! the file! /config
YAGPDB.xyz
YAGPDB.xyz4w ago
To edit the config, press the button next to the FOV slider to edit the config. The config file found in .minecraft/config/DistantHorizons.toml
Shayn-Keta
Shayn-Keta4w ago
ohhhh oops mb
Miki_P98
Miki_P984w ago
.minecraft/config/DistantHorizons.toml
Shayn-Keta
Shayn-Keta4w ago
allright deleted it and restarted the game
Miki_P98
Miki_P984w ago
Corrected the messaage to be more precise
Shayn-Keta
Shayn-Keta4w ago
so lets see
Shayn-Keta
Shayn-Keta4w ago
hmmnnn so it partially works now
No description
Puhpine
Puhpine4w ago
yep looks to be working but LODs will load slowly it will take time
Miki_P98
Miki_P984w ago
/slowgen
YAGPDB.xyz
YAGPDB.xyz4w ago
If it feels like LoD generation with Distant Generator is too slow: Try increasing CPU Load in Distant Horizons settings for faster generation, but you will experience more lag spikes and stuttering due to heavier workload on CPU. To see if Distant Generator is really working or not: 1) Check CPU usage while in-game, using Aggressive settings of CPU Load. If CPU usage's hovering around 80-100%, the LoDs are generating in the background. 2) Go to DH settings > Advanced Options > Debug > Wireframe, set Enable Debug Wireframe Rendering and Show World Gen Queue to True. Enabling both settings will show you the visualization of world gen tasks queued and working on the map (blue boxes for queued tasks, red boxes for working tasks)
Miki_P98
Miki_P984w ago
You can try installing mods: - Noisium - Faster Random They will speed it up a bit
Shayn-Keta
Shayn-Keta4w ago
allright will give a look into that! problem with increasing workload is that its already at 100 when i have it on balanced
Puhpine
Puhpine4w ago
how much ram do you have allocated?
Shayn-Keta
Shayn-Keta4w ago
4, and when im running the game im using 14 out of 16 gigs
Shayn-Keta
Shayn-Keta4w ago
this is how much i have left when im not running the game
No description
Shayn-Keta
Shayn-Keta4w ago
so figured 4 would be a solid bet
Miki_P98
Miki_P984w ago
So you have 16 GiB in your system allocated 14 GiB to MC, and out of that MC is using 4 GiB? or have you allocated 4 GiB?
Shayn-Keta
Shayn-Keta4w ago
that cuz i thought rule of thumb would be to use 60/70 percent of your available ram to allocate it for minecraft
Puhpine
Puhpine4w ago
what is using the other 10 gigs?
Shayn-Keta
Shayn-Keta4w ago
i have noisium now but faster random i see is only for fabric/quilt
Shayn-Keta
Shayn-Keta4w ago
i guess google chrome lol
No description
Puhpine
Puhpine4w ago
oof how many tabs?
Shayn-Keta
Shayn-Keta4w ago
21 atm if i close chrome
Shayn-Keta
Shayn-Keta4w ago
No description
Shayn-Keta
Shayn-Keta4w ago
so significant difference ig, but i do use chrome for reference pics whenever im building and its just convenient to have a browser open to look up stuff
Puhpine
Puhpine4w ago
you need 21 tabs for that though? i know its not that many tabs but it is chrome...
Shayn-Keta
Shayn-Keta4w ago
lol fair enough
Puhpine
Puhpine4w ago
so try 6 or 8 with fewer tabs open and see if that makes a difference
Shayn-Keta
Shayn-Keta4w ago
i only have 6 tabs rn
No description
Shayn-Keta
Shayn-Keta4w ago
but almost no difference lol
Puhpine
Puhpine4w ago
oof that sucks
Shayn-Keta
Shayn-Keta4w ago
do u know if firefox is a ram friendly browser?
Puhpine
Puhpine4w ago
try 6 or 8 anyway i think its better than chrome. i have no idea by how much
Shayn-Keta
Shayn-Keta4w ago
cuz i also got that installed, so might as well switch to it for gaming if so
Puhpine
Puhpine4w ago
worth a try
Shayn-Keta
Shayn-Keta4w ago
yeah, slightly
No description
Shayn-Keta
Shayn-Keta4w ago
oh well either way, is 4 ram allocated to minecraft enough? or would I need more
Miki_P98
Miki_P984w ago
depends my MC fills up to 14 GiB, but I have DH RD at 1024 and a lot of ambient mods and hi-res resourcepacks
Puhpine
Puhpine4w ago
depends on what you are doing. for generating new LODs, more is recommended
Shayn-Keta
Shayn-Keta4w ago
ill give 6 a try
Shayn-Keta
Shayn-Keta4w ago
hmm 6 ram, aggressive cpu setting but still this
No description
Puhpine
Puhpine4w ago
its not fast it will take a while disabling shaders might speed it up a little
Shayn-Keta
Shayn-Keta4w ago
ohhh okayyy do i need to turn on distant generation as well for it to work better
Puhpine
Puhpine4w ago
oh, you had that off? well it wont generate distant LODs if distant generation is off
Shayn-Keta
Shayn-Keta4w ago
no i had it on, but just wondering cuz it said that it costs a lot of cpu power but that makes sense lol certain chunks dont load until i get there but then they stay loaded. Thats how its supposed to go right? or should the environment load all the time around me cuz now all the chunks where ive been are loaded, but u have this narrow area where i can look till the horizon
Puhpine
Puhpine4w ago
just wait a while. it will fix itself. turn all vanilla video settings to a low amount, turn cpu load up, and let it rest for 30 minutes when you come back a good chunk of world should be loaded
Shayn-Keta
Shayn-Keta4w ago
allright thank u!
Puhpine
Puhpine4w ago
np!
Shayn-Keta
Shayn-Keta4w ago
i got a few more questions if you dont mind, but ill make a seperate thread for that :)
Puhpine
Puhpine4w ago
sure