R
Railway2mo ago
Sam

Can't connect Railway app to Cloudfare DNS

Hi, I am having a problem connecting the DNS settings given to me by Railway to Cloufare, which now handles my DNS settings. I tried entering the information given to me by Railway, but Cloudfare says that a record already exists (but when I search all my DNS records, none of them match the information given by railway). Any advice or troubleshooting feedback is appreciated!
Solution:
So I should delete the A type records and then try to add the CNAME record?
Jump to solution
16 Replies
Percy
Percy2mo ago
Project ID: N/A
Sam
Sam2mo ago
N/A
Brody
Brody2mo ago
screenshot of the cloudflare dns settings please this screenshot is not helpfull?
Sam
Sam2mo ago
Sorry I realized you said settings One moment
Brody
Brody2mo ago
you had it correct the first time
Sam
Sam2mo ago
No description
Brody
Brody2mo ago
you do have duplicates there duplicate by name, not by type
Sam
Sam2mo ago
Are you referencing the A names being duplicates? Should I delete them and just leave one of the A names?
Brody
Brody2mo ago
you dont want any A types though
Sam
Sam2mo ago
Why? Because of the IP addresses? Sorry I am new to this so I don't always understand what the different types are
Brody
Brody2mo ago
Railway does not give you an IP address, they give you a CNAME
Sam
Sam2mo ago
Oh yes, but when I try and put that CNAME in it says I have duplicates. The duplicates are the A types by name correct?
Brody
Brody2mo ago
correct
Solution
Sam
Sam2mo ago
So I should delete the A type records and then try to add the CNAME record?
Brody
Brody2mo ago
correct
Sam
Sam2mo ago
Let me try that and get back to you That worked, thank you. Now when I go to mypetnote.com, it shows the railway project that I wanted to connect. Thank you so much! Can you mark this as solved please?