Tried using the new iris and DH release for 1.20.1, now my game wont load.

I was trying to optimize my game again, I saw in-game that there was an update for Iris, and I remembered seeing one for DH as well. I installed both, now the game wont load.
22 Replies
Mr Hooga
Mr Hooga2mo ago
I saw on another post that DH 2.0.2 is no longer compatible with Iris 1.7, Is that still true for 1.20.1?
MarijnIsN00B
MarijnIsN00B2mo ago
Yes, use 2.0.3
Mr Hooga
Mr Hooga2mo ago
It says it is for 1.20.4, Will it work with 1.20.1, or is there one for that version as well?
MarijnIsN00B
MarijnIsN00B2mo ago
I dont think so but /tryitandsee
Mr Hooga
Mr Hooga2mo ago
ok, I'll give it a shot lol Yeah, doesn't work. is there a build of DH 2.0.3 that is for 1.20.1?
MarijnIsN00B
MarijnIsN00B2mo ago
I dont think so atm
Mr Hooga
Mr Hooga2mo ago
Or do I just have to go back to an older version of Iris?
Yeshi
Yeshi2mo ago
1 sec gotta find the link for it. It does exist
Mr Hooga
Mr Hooga2mo ago
oh?
Yeshi
Yeshi2mo ago
https://gitlab.com/jeseibel/distant-horizons/-/jobs/artifacts/Data_Source_Rewrite/download?job=build:%20[1.20.1] This should always be up to date with what's on the data source rewrite branch (2.0.3)
Mr Hooga
Mr Hooga2mo ago
ok, i'll try it out, thanks it gives a 404 on github
Yeshi
Yeshi2mo ago
Might even exist for older versions Ah rip I might try finding an older archive of the jar Hang on
Mr Hooga
Mr Hooga2mo ago
ok
Yeshi
Yeshi2mo ago
If you're feeling real experimental you could try https://discord.com/channels/881614130614767666/961441646967406593/1225418048803049502 but don't expect it to work at all (and make a copy of your sqlite first) Best idea would be to wait for the full release though
Mr Hooga
Mr Hooga2mo ago
I guess I'll just /tryitandsee
Mr Hooga
Mr Hooga2mo ago
I already can just barely run it anyways lol at a solid 10fps lol The game loads up now, but when I load into my world, it'll get to 100%, say "joining game", then crash.
Mr Hooga
Mr Hooga2mo ago
I am using the unstable build, so I'm not expecting it to work lol
Yeshi
Yeshi2mo ago
prob best to keep playing on 2.0.2 without shaders for the time being and waiting for the full release
Mr Hooga
Mr Hooga2mo ago
ah, ok, thx