Activate SSL on my custom domain

Hello, I bought the domain apocolinks.com at DreamHost.com, this domain already has an active SSL certificate, but for some reason I can make the certificate I have work with the custom domain that I have put in my Railway project, do you have an idea? How could I solve this problem, I would really appreciate it.
Solution:
remove the domain from railway and add it back, do not touch anything dns related
Jump to solution
37 Replies
Percy
Percy3mo ago
Project ID: N/A
Brody
Brody3mo ago
railway handles SSL for you, and dreamhost does not support root level cnames, you would need to use cloudflare's nameservers
fespinoza95
fespinoza953mo ago
No description
Brody
Brody3mo ago
okay you're not using a root level domain please show me the dns setup
fespinoza95
fespinoza953mo ago
Do you mean I should buy another domain with cloudflar's nameservers?
Brody
Brody3mo ago
not at all please show me your dns settings
fespinoza95
fespinoza953mo ago
ok give me a minute
Brody
Brody3mo ago
it was just an observation, it wasn't an actionable request
fespinoza95
fespinoza953mo ago
No description
Brody
Brody3mo ago
how long has it been at issuing tls certificate
fespinoza95
fespinoza953mo ago
I think I activated it a month ago
Brody
Brody3mo ago
you added the domain a month ago and just now are asking for help?
fespinoza95
fespinoza953mo ago
I didn't, buy the domain a month or more ago, but until recently I was trying to use a custom domain on railway
Brody
Brody3mo ago
okay so then please answer the question
fespinoza95
fespinoza953mo ago
Do you mean when I activated the tls certificate on dreamhost?
Brody
Brody3mo ago
not at all, but moving on
Solution
Brody
Brody3mo ago
remove the domain from railway and add it back, do not touch anything dns related
fespinoza95
fespinoza953mo ago
ok ready
Brody
Brody3mo ago
what does railway say the status of the domain is now?
fespinoza95
fespinoza953mo ago
I see this
No description
Brody
Brody3mo ago
the site works for me
fespinoza95
fespinoza953mo ago
yes it works
Brody
Brody3mo ago
awsome
fespinoza95
fespinoza953mo ago
but I couldn't activate the ssl certificate
No description
Brody
Brody3mo ago
railway handles ssl for you, please dont do anything ssl related yourself that should resolve itself for you, i dont get any issues with ssl
fespinoza95
fespinoza953mo ago
okay thanks for your time and information
Brody
Brody3mo ago
no problem
driesvdb
driesvdb3mo ago
when do they remove the SLL after you close the service? I still have it on m domain after pointing my domain cname to a not railway app. keep having SSL_ERROR_BAD_CERT_DOMAIN and certificate Common Name *.up.railway.app
Brody
Brody3mo ago
have you gotten yourself another cert issued elsewhere?
driesvdb
driesvdb3mo ago
the domain it is pointing to know has a cert yes app2.robuxio.com I am pointing it to the same endpoint as this app now on app.robuxio.com i used to run my railway application
Brody
Brody3mo ago
what domain are you having issues with
driesvdb
driesvdb3mo ago
app.robuxio.com
Brody
Brody3mo ago
where is it hosted
driesvdb
driesvdb3mo ago
used to be on railway, but cancelled yesterday as i am moving to AWS (i will for sure use railway again to host dev)
Brody
Brody3mo ago
is the domain now just pointing to an ec2 instance or something?
driesvdb
driesvdb3mo ago
cloudfront
Brody
Brody3mo ago
does that provide you with automatic ssl?